Follow Us on Twitter

A few more considerations when upgrading OFM to PS5

by Laurens van der Starre on March 10, 2012 · 6 comments

Recently I wrote a blog post with some quick tips for upgrading your Oracle Fusion Middleware to PS5. Well now, in this post I give fome more considerations about the update that I found out during an upgrade from patch set 2 to patch set 5.

JDK 7
A look into the Certification Matrix reveals that OFM 11.1.1.6.0 must run on JDK 1.7.0_02+. So no jRockit. Please be aware that JDK 7 is not certified with WLS 10.3.5. This means that while it is possible to run your 11gPS5 OFM applications in WLS 10.3.5, it will be an uncertified system. A bit confusing if you ask me…

NodeManager
Do not forget to shutdown the nodemanager when upgrading. If you have upgraded your middleware home and domain, and left the nodemanager running, you can’t start your server through the nodemanager. It will say that it WLS version is incorrect. Quick fix: restart the nodemanager.

OWSM SOA Suite
If your domain has OWSM installed, you have to update the OWSM predefined policies. This is especially important if you’re upgrading from PS2. If you forget this, the WorklistApp will not work.

It’s an online script, but the instructions are a bit vague. Run this script from the WLST from <MIDDLEWARE_HOME>/Oracle_SOA1/common/bin! Otherwise upgradeWSMPolicyRepository() can’t be found.

OWSM and OSB
If you have an OSB domain with OWSM, and are upgrading from PS2, not installing the OWSM predefined policies will kill the OSB’s Project Explorer on the sbconsole. However, there’s a tricky part. Because you have an OSB only domain, there is no Oracle_SOA1/common/bin, and somehow during my upgrade WLST couldn’t find the upgradeWSMPolicyRepository() procedure. This particular procedure comes from oracle_common/common/wlst/wsmManage.py, so if it is somehow not in your WLST path, you know where to find it.

The OSB nodemanager
Upgrading an OSB-only domain from PS2 to PS5 tends to affect the nodemanager.domains config file in the NodeManager-HOME. Inother words: the nodemanager can’t find the domain anymore. The solution is simply to use nmEnroll() in WLST to enroll your domain with the nodemanager again.

The PSA performance
The Patch Set Assistant is used for upgrading MDS or MDS+SOA-INFRA databases. A reference performance benchmark could be:
A ~200GB PS2 SOA-INFRA database took approximately 1.5hrs to upgrade to PS5. So that is not too bad. I don’t know the exact specs of the database, but it was a dataguard setup with fast enough storage to minimise that bottleneck.

Please make sure that before running the PSA, all database user rights are set as they were at installation. The DBA might follow the “Practice The Principle Of Least Privilege”, meaning that the SOA-INFRA database user might not have the appropriate set of grants needed to perform the PSA upgrade. This is especially true when you come from PS2. In this case the PSA will fail, and you’ll have to restore a database backup and start over.

A few more considerations when upgrading OFM to PS5, 4.0 out of 5 based on 2 ratings
Ratings:
VN:F [1.9.22_1171]
Rating: 4.0/5 (2 votes cast)

{ 5 comments… read them below or add one }

Jaap March 13, 2012 at 11:36 am

“OFM 11.1.1.6.0 must run on JDK 1.7.0_02+”. It CAN run on JDK 7, right (i.e. certified)?
It’s still certified with Oracle JDK 1.6.0_29+ and JRockit 6 Update 29 R28.2.0+.

Reply

Ray T April 3, 2012 at 10:00 am

Hi Laurens & thankyou for your post.

That Certification Matrix that you refer to in your section on JDKs can be a hiddeous beast to decipher can’t it. Initially I too was left thinking that OFM 11.1.1.6 requires Oracle JDK 1.7.0_02+ “only”.

But keeping in mind that Oracle state “Oracle Fusion Middleware 11.1.1.6.0 is certified with WebLogic Server 10.3.5 and 10.3.6” and having yet another fresh look at the matrix I could suddenly see the interpretation that Jaap commented on. I can now see looking at the JDK “column” for 11.1.1.6, how the matrix can be interpreted to mean that you can use either Oracle JDK 1.6.0_29+ or JRockit 6u29(R28.2.0+) or Oracle JDK 1.7.0_02+ And if you look at the many “rows” that incl ALL or Weblogic Server in installation type of the 11.1.1.5 stack then Oracle JDK 1.6.0_29+ or JRockit 6u29(R28.2.0+) should be certified with a WLS 10.3.5 & FMW 11.1.1.6 combination. I am currently seeking absolute confirmation of this interpretation with Support.

I also take it that when you comment “So no jRockit.” in relation to JDK7 that you are referring to the fact that JRockit is in the process of being absorbed by Oracle JDK starting with JDK7; so there will be no JRockit 7 or beyond.

Thanks again

Reply

Laurens van der Starre April 13, 2012 at 1:03 pm

Yes, you are right. It is a bit confusing. If I interpret de Certification Matrix it clearly hints on JDK 7, however, like a mentioned, and like you also comment, that doesn’t make sense because PS5 can be run on WLS 10.3.5. Let me now what the result is of your confirmation with Support.

Reply

Ray T April 14, 2012 at 7:12 am

Hi again Laurens,

Well I have confirmation back from support and they have agreed – “Oracle JDK 1.6.0_29+ or JRockit 6u29(R28.2.0+) is certified with a WLS 10.3.5 & FMW 11.1.1.6 combination”

Cheers
Ray

Reply

Laurens van der Starre April 15, 2012 at 2:28 pm

Hi Ray,
Great, good to know! I expected something like this, but you can never be too careful with the certification matrix. The last thing you’d want is Support not helping you because the system is uncertified 😉

Thanks!

Reply

Leave a Comment

 

{ 1 trackback }

Previous post:

Next post:

About Whitehorses
Company profile
Services
Technology

Whitehorses website

Home page
Whitebooks
Jobs

Follow us
Blog post RSS
Comment RSS
Twitter